clocksource: hyper-v: unexport __init-annotated hv_init_clocksource()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-908 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: clocksource: hyper-v: unexport __init-annotated hv_init_clocksource() EXPORT_SYMBOL and __init is a bad combination because the .init.text section is freed up after the initialization. Hence, modules cannot use symbols annotated __init. The access to a freed symbol may end up with kernel panic. modpost used to detect it, but it has been broken for a decade. Recently, I fixed modpost so it started to warn it again, then this showed up in linux-next builds. There are two ways to fix it: - Remove __init - Remove EXPORT_SYMBOL I chose the latter for this case because the only in-tree call-site, arch/x86/kernel/cpu/mshyperv.c is never compiled as modular. (CONFIG_HYPERVISOR_GUEST is boolean)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.3 and later | 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 5.3 and later Fixed in 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.3 to before 5.4.200; 5.5 to before 5.10.124; 5.11 to before 5.15.49; 5.16 to before 5.18.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.3 to before 5.4.200; 5.5 to before 5.10.124; 5.11 to before 5.15.49; 5.16 to before 5.18.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.200, 5.10.124, 5.15.49, 5.18.6, 5.19
Red Hat 2 advisories
- RHSA-2023:2951 Released 2023-05-16 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-477.10.1.el8_8, kernel-4.18.0-477.10.1.el8_8, kernel-abi-stablelists-4.18.0-477.10.1.el8_8 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-477.10.1.el8_8
- RHSA-2023:2458 Released 2023-05-09 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-284.11.1.el9_2, kernel-64k-debug-devel-matched-5.14.0-284.11.1.el9_2, kernel-64k-devel-5.14.0-284.11.1.el9_2 +10
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-7.0.0-284.11.1.el9_2, kernel-5.14.0-284.11.1.el9_2, kernel-64k-5.14.0-284.11.1.el9_2 +29
- Red Hat Enterprise Linux CRB (v. 9) kernel-tools-libs-devel-5.14.0-284.11.1.el9_2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:2458 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2023:2951 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2023:2458 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2023:2951 |
| Red Hat Enterprise Linux CRB (v. 9) | Fixed | RHSA-2023:2458 |
Not affected: 3 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49726
- 2026-10-03 Alias added: GHSA-3pj9-hhgf-f53q
References
Patch 5
- https://git.kernel.org/stable/c/cff3a7ce6e81418b6e8bac941779bbf5d342d626
- https://git.kernel.org/stable/c/db965e2757d95f695e606856418cd84003dd036d
- https://git.kernel.org/stable/c/0414eab7c78f3518143d383e448d44fc573ac6d2
- https://git.kernel.org/stable/c/937fcbb55a1e48a6422e87e8f49422c92265f102
- https://git.kernel.org/stable/c/245b993d8f6c4e25f19191edfbd8080b645e12b1
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49726 · CVE Program
- CVE-2022-49726 · NVD
- FIRST EPSS
- GHSA-3pj9-hhgf-f53q · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49726 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences