EDAC/highbank: Fix memory leak in highbank_mc_probe()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: EDAC/highbank: Fix memory leak in highbank_mc_probe() When devres_open_group() fails, it returns -ENOMEM without freeing memory allocated by edac_mc_alloc(). Call edac_mc_free() on the error handling path to avoid a memory leak. [ bp: Massage commit message. ]
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.6 and later | 4.14.305, 4.19.272, 5.4.231, 5.10.166, 5.15.91, 6.1.9, 6.2 | Patch available | CNA |
- Linux VendorLinux Affected 3.6 and later Fixed in 4.14.305, 4.19.272, 5.4.231, 5.10.166, 5.15.91, 6.1.9, 6.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.6 to before 4.14.305; 4.15 to before 4.19.272; 4.20 to before 5.4.231; 5.5 to before 5.10.166; 5.11 to before 5.15.91; 5.16 to before 6.1.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* | 6.2 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* | 6.2 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc3:*:*:*:*:*:* | 6.2 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.6 to before 4.14.305; 4.15 to before 4.19.272; 4.20 to before 5.4.231; 5.5 to before 5.10.166; 5.11 to before 5.15.91; 5.16 to before 6.1.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* Versions 6.2 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* Versions 6.2 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc3:*:*:*:*:*:* Versions 6.2 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.305, 4.19.272, 5.4.231, 5.10.166, 5.15.91, 6.1.9, 6.2
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49757
- 2026-10-03 Alias added: GHSA-xvxr-rrxw-rfp9
References
Patch 7
- https://git.kernel.org/stable/c/f1b3e23ed8df87d779ee86ac37f379e79a24169a
- https://git.kernel.org/stable/c/0db40e23b56d217eebd385bebb64057ef764b2c7
- https://git.kernel.org/stable/c/8d23f5d25264beb223ee79cdb530b88c237719fc
- https://git.kernel.org/stable/c/329fbd260352a7b9a83781d8b8bd96f95844a51f
- https://git.kernel.org/stable/c/caffa7fed1397d1395052272c93900176de86557
- https://git.kernel.org/stable/c/b7863ef8a8f0fee96b4eb41211f4918c0e047253
- https://git.kernel.org/stable/c/e7a293658c20a7945014570e1921bf7d25d68a36
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49757 · CVE Program
- CVE-2022-49757 · NVD
- FIRST EPSS
- GHSA-xvxr-rrxw-rfp9 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49757 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences