Read the docs
TI-2022-25272 Aliases CVE-2022-49771GHSA-qp86-w2fg-h37h

dm ioctl: fix misbehavior if list_versions races with module loading

Priority LOW 21CWE-362Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 4 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: dm ioctl: fix misbehavior if list_versions races with module loading __list_versions will first estimate the required space using the "dm_target_iterate(list_version_get_needed, &needed)" call and then will fill the space using the "dm_target_iterate(list_version_get_info, &iter_info)" call. Each of these calls locks the targets using the "down_read(&_lock)" and "up_read(&_lock)" calls, however between the first and second "dm_target_iterate" there is no lock held and the target modules can be loaded at this point, so the second "dm_target_iterate" call may need more space than what was the first "dm_target_iterate" returned. The code tries to handle this overflow (see the beginning of list_version_get_info), however this handling is incorrect. The code sets "param->data_size = param->data_start + needed" and "iter_info.end = (char *)vers+len" - "needed" is the size returned by the first dm_target_iterate call; "len" is the size of the buffer allocated by userspace. "len" may be greater than "needed"; in this case, the code will write up to "len" bytes into the buffer, however param->data_size is set to "needed", so it may write data past the param->data_size value. The ioctl interface copies only up to param->data_size into userspace, thus part of the result will be truncated. Fix this bug by setting "iter_info.end = (char *)vers + needed;" - this guarantees that the second "dm_target_iterate" call will write only up to the "needed" buffer and it will exit with "DM_BUFFER_FULL_FLAG" if it overflows the "needed" space - in this case, userspace will allocate a larger buffer and retry. Note that there is also a bug in list_version_get_needed - we need to add "strlen(tt->name) + 1" to the needed size, not "strlen(tt->name)".

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00159 5th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.9.334, 4.14.300, 4.19.267 +5Red Hat: 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux2.6.12 and later4.9.334, 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1Patch availableCNA
  • Linux VendorLinux Affected 2.6.12 and later Fixed in 4.9.334, 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*before 4.9.334; 4.10 to before 4.14.300; 4.15 to before 4.19.267; 4.20 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:*6.1 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:*6.1 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:*6.1 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:*6.1 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:*6.1 rc5VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.9.334; 4.10 to before 4.14.300; 4.15 to before 4.19.267; 4.20 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* Versions 6.1 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* Versions 6.1 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* Versions 6.1 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:* Versions 6.1 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:* Versions 6.1 rc5 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 4.9.334, 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 8AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred
Not affected: 1 product
  • Red Hat Enterprise Linux 10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-49771
  2. 2026-10-03 Alias added: GHSA-qp86-w2fg-h37h
  3. 2026-11-05 CISA SSVC decision points changed

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources