macvlan: enforce a consistent minimal mtu
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: macvlan: enforce a consistent minimal mtu macvlan should enforce a minimal mtu of 68, even at link creation. This patch avoids the current behavior (which could lead to crashes in ipv6 stack if the link is brought up) $ ip link add macvlan1 link eno1 mtu 8 type macvlan # This should fail ! $ ip link sh dev macvlan1 5: macvlan1@eno1: <BROADCAST,MULTICAST> mtu 8 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 02:47:6c:24:74:82 brd ff:ff:ff:ff:ff:ff $ ip link set macvlan1 mtu 67 Error: mtu less than device minimum. $ ip link set macvlan1 mtu 68 $ ip link set macvlan1 mtu 8 Error: mtu less than device minimum.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.10 and later | 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1 | Patch available | CNA |
- Linux VendorLinux Affected 4.10 and later Fixed in 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.10 to before 4.14.300; 4.15 to before 4.19.267; 4.20 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.10 to before 4.14.300; 4.15 to before 4.19.267; 4.20 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.300, 4.19.267, 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Enterprise Linux 10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49776
- 2026-10-03 Alias added: GHSA-gpc4-vc7c-37hj
- 2026-11-05 CISA SSVC decision points changed
References
Patch 7
- https://git.kernel.org/stable/c/d2fee7d121d189c6dc905b727d60e7043a6655bb
- https://git.kernel.org/stable/c/650137a7c0b2892df2e5b0bc112d7b09a78c93c8
- https://git.kernel.org/stable/c/a62aa84fe19eb24d083d600a074c009a0a66d4f3
- https://git.kernel.org/stable/c/e929ec98c0c3b10d9c07f3776df0c1a02d7a763e
- https://git.kernel.org/stable/c/e41cbf98df22d08402e65174d147cbb187fe1a33
- https://git.kernel.org/stable/c/2b055c719d8f94c15ec9b7659978133030c6a353
- https://git.kernel.org/stable/c/b64085b00044bdf3cd1c9825e9ef5b2e0feae91a
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49776 · CVE Program
- CVE-2022-49776 · NVD
- FIRST EPSS
- GHSA-gpc4-vc7c-37hj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49776 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences