Input: iforce - invert valid length check when fetching device IDs
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-908 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: Input: iforce - invert valid length check when fetching device IDs syzbot is reporting uninitialized value at iforce_init_device() [1], for commit 6ac0aec6b0a6 ("Input: iforce - allow callers supply data buffer when fetching device IDs") is checking that valid length is shorter than bytes to read. Since iforce_get_id_packet() stores valid length when returning 0, the caller needs to check that valid length is longer than or equals to bytes to read.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.3 and later | 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1 | Patch available | CNA |
- Linux VendorLinux Affected 5.3 and later Fixed in 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.3 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* | 6.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* | 6.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* | 6.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:* | 6.1 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:* | 6.1 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.3 to before 5.4.225; 5.5 to before 5.10.156; 5.11 to before 5.15.80; 5.16 to before 6.0.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* Versions 6.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* Versions 6.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* Versions 6.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc4:*:*:*:*:*:* Versions 6.1 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc5:*:*:*:*:*:* Versions 6.1 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.225, 5.10.156, 5.15.80, 6.0.10, 6.1
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49790
- 2026-10-03 Alias added: GHSA-3x3q-3c9j-4x72
References
Patch 5
- https://git.kernel.org/stable/c/5d53797ce7ce8fb1d95a5bebc5efa9418c4217a3
- https://git.kernel.org/stable/c/24cc679abbf31477d0cc6106ec83c2fbae6b3cdf
- https://git.kernel.org/stable/c/fdd57c20d4408cac3c3c535c120d244e083406c9
- https://git.kernel.org/stable/c/6365569d62a75ddf53fb0c2936c16587a365984c
- https://git.kernel.org/stable/c/b8ebf250997c5fb253582f42bfe98673801ebebd
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49790 · CVE Program
- CVE-2022-49790 · NVD
- FIRST EPSS
- GHSA-3x3q-3c9j-4x72 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49790 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences