s390: avoid using global register for current_stack_pointer
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: s390: avoid using global register for current_stack_pointer Commit 30de14b1884b ("s390: current_stack_pointer shouldn't be a function") made current_stack_pointer a global register variable like on many other architectures. Unfortunately on s390 it uncovers old gcc bug which is fixed only since gcc-9.1 [gcc commit 3ad7fed1cc87 ("S/390: Fix PR89775. Stackpointer save/restore instructions removed")] and backported to gcc-8.4 and later. Due to this bug gcc versions prior to 8.4 generate broken code which leads to stack corruptions. Current minimal gcc version required to build the kernel is declared as 5.1. It is not possible to fix all old gcc versions, so work around this problem by avoiding using global register variable for current_stack_pointer.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.18 and later | 6.0.10, 6.1 | Patch available | CNA |
- Linux VendorLinux Affected 5.18 and later Fixed in 6.0.10, 6.1 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.18.1 to before 6.0.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* | 5.18 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* | 5.18 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc4:*:*:*:*:*:* | 5.18 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc5:*:*:*:*:*:* | 5.18 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc6:*:*:*:*:*:* | 5.18 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc7:*:*:*:*:*:* | 5.18 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* | 6.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* | 6.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* | 6.1 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.18.1 to before 6.0.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* Versions 5.18 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* Versions 5.18 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc4:*:*:*:*:*:* Versions 5.18 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc5:*:*:*:*:*:* Versions 5.18 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc6:*:*:*:*:*:* Versions 5.18 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc7:*:*:*:*:*:* Versions 5.18 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc1:*:*:*:*:*:* Versions 6.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc2:*:*:*:*:*:* Versions 6.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.1:rc3:*:*:*:*:*:* Versions 6.1 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.0.10, 6.1
Red Hat 1 advisory
- RHSA-2025:6966 Released 2025-05-13 · Red Hat rating Moderatekernel security update
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-570.12.1.el9_6, kernel-64k-debug-devel-matched-5.14.0-570.12.1.el9_6, kernel-64k-devel-5.14.0-570.12.1.el9_6 +12
- Red Hat Enterprise Linux BaseOS (v. 9) kernel-5.14.0-570.12.1.el9_6, kernel-64k-5.14.0-570.12.1.el9_6, kernel-64k-core-5.14.0-570.12.1.el9_6 +28
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-570.12.1.el9_6, libperf-5.14.0-570.12.1.el9_6
- Red Hat Enterprise Linux Real Time (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-64k-5.14.0-570.12.1.el9_6, kernel-rt-64k-core-5.14.0-570.12.1.el9_6 +21
- Red Hat Enterprise Linux Real Time for NFV (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-core-5.14.0-570.12.1.el9_6, kernel-rt-debug-5.14.0-570.12.1.el9_6 +11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time for NFV (v. 9) | Fixed | RHSA-2025:6966 |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-49804
- 2026-10-03 Alias added: GHSA-6mx2-jh62-9j5h
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-49804 · CVE Program
- CVE-2022-49804 · NVD
- FIRST EPSS
- GHSA-6mx2-jh62-9j5h · GitHub Advisory Database · CC BY 4.0
- CVE-2022-49804 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences