netfilter: nft_tproxy: restrict to prerouting hook
Priority LOW 24Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: netfilter: nft_tproxy: restrict to prerouting hook TPROXY is only allowed from prerouting, but nft_tproxy doesn't check this. This fixes a crash (null dereference) when using tproxy from e.g. output.
Why it matters now
EPSS 0.00194 9th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.19.273, 5.4.232, 5.10.169 +3Red Hat: 2 advisoriesRed Hat: 5 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19 and later | 4.19.273, 5.4.232, 5.10.169, 5.15.95, 5.19.6, 6.0 | Patch available | CNA |
- Linux VendorLinux Affected 4.19 and later Fixed in 4.19.273, 5.4.232, 5.10.169, 5.15.95, 5.19.6, 6.0 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.19 to before 4.19.273; 4.20 to before 5.4.232; 5.5 to before 5.10.169; 5.11 to before 5.15.95; 5.16 to before 5.19.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.0:rc1:*:*:*:*:*:* | 6.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.0:rc2:*:*:*:*:*:* | 6.0 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19 to before 4.19.273; 4.20 to before 5.4.232; 5.5 to before 5.10.169; 5.11 to before 5.15.95; 5.16 to before 5.19.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.0:rc1:*:*:*:*:*:* Versions 6.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.0:rc2:*:*:*:*:*:* Versions 6.0 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.273, 5.4.232, 5.10.169, 5.15.95, 5.19.6, 6.0
Red Hat 2 advisories
- RHSA-2023:2951 Released 2023-05-16 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-477.10.1.el8_8, kernel-4.18.0-477.10.1.el8_8, kernel-abi-stablelists-4.18.0-477.10.1.el8_8 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-477.10.1.el8_8
- RHSA-2022:8267 Released 2022-11-15 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-162.6.1.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) kernel-debug-devel-5.14.0-162.6.1.el9_1, kernel-debug-devel-matched-5.14.0-162.6.1.el9_1, kernel-devel-5.14.0-162.6.1.el9_1 +5
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-5.14.0-162.6.1.el9_1, kernel-5.14.0-162.6.1.el9_1, kernel-abi-stablelists-5.14.0-162.6.1.el9_1 +14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2023:2951 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2023:2951 |
Not affected: 3 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-50001
- 2026-10-03 Alias added: GHSA-p2g8-3w2w-p6gf
References
Patch 6
- https://git.kernel.org/stable/c/0b21edf4cc13516716848e0a4fdf726aa2a62cd9
- https://git.kernel.org/stable/c/83ef55c4281f1b4c6bd4457c2e96ccd1c9e80200
- https://git.kernel.org/stable/c/eaba3f9b672c3a3f820da8ee9584b9520674eafa
- https://git.kernel.org/stable/c/9a1d92cbeac3335fee99fa865b8c5b0f2e71a8f7
- https://git.kernel.org/stable/c/343fed6b0daeb528ae5c9d4d84d9ff763ac95619
- https://git.kernel.org/stable/c/18bbc3213383a82b05383827f4b1b882e3f0a5a5
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-50001 · CVE Program
- CVE-2022-50001 · NVD
- FIRST EPSS
- GHSA-p2g8-3w2w-p6gf · GitHub Advisory Database · CC BY 4.0
- CVE-2022-50001 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences