video: fbdev: s3fb: Check the size of screen before memset_io()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: video: fbdev: s3fb: Check the size of screen before memset_io() In the function s3fb_set_par(), the value of 'screen_size' is calculated by the user input. If the user provides the improper value, the value of 'screen_size' may larger than 'info->screen_size', which may cause the following bug: [ 54.083733] BUG: unable to handle page fault for address: ffffc90003000000 [ 54.083742] #PF: supervisor write access in kernel mode [ 54.083744] #PF: error_code(0x0002) - not-present page [ 54.083760] RIP: 0010:memset_orig+0x33/0xb0 [ 54.083782] Call Trace: [ 54.083788] s3fb_set_par+0x1ec6/0x4040 [ 54.083806] fb_set_var+0x604/0xeb0 [ 54.083836] do_fb_ioctl+0x234/0x670 Fix the this by checking the value of 'screen_size' before memset_io().
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.21 and later | 4.14.291, 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.21 and later Fixed in 4.14.291, 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.21 to before 4.14.291; 4.15 to before 4.19.256; 4.20 to before 5.4.211; 5.5 to before 5.10.137; 5.11 to before 5.15.61; 5.16 to before 5.18.18; 5.19 to before 5.19.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.21 to before 4.14.291; 4.15 to before 4.19.256; 4.20 to before 5.4.211; 5.5 to before 5.10.137; 5.11 to before 5.15.61; 5.16 to before 5.18.18; 5.19 to before 5.19.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.291, 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-50097
- 2026-10-03 Alias added: GHSA-9xgq-whmc-w683
- 2026-11-07 Affected versions changed · Red Hat
References
Patch 8
- https://git.kernel.org/stable/c/574912261528589012b61f82d368256247c3a5a8
- https://git.kernel.org/stable/c/3c35a0dc2b4e7acf24c796043b64fa3eee799239
- https://git.kernel.org/stable/c/eacb50f1733660911827d7c3720f4c5425d0cdda
- https://git.kernel.org/stable/c/5e0da18956d38e7106664dc1d06367b22f06edd3
- https://git.kernel.org/stable/c/ce50d94afcb8690813c5522f24cd38737657db81
- https://git.kernel.org/stable/c/52461d387cc8c8f8dc40320caa2e9e101f73e7ba
- https://git.kernel.org/stable/c/e2d7cacc6a2a1d77e7e20a492daf458a12cf19e0
- https://git.kernel.org/stable/c/6ba592fa014f21f35a8ee8da4ca7b95a018f13e8
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-50097 · CVE Program
- CVE-2022-50097 · NVD
- FIRST EPSS
- GHSA-9xgq-whmc-w683 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-50097 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences