HID: cp2112: prevent a buffer overflow in cp2112_xfer()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: HID: cp2112: prevent a buffer overflow in cp2112_xfer() Smatch warnings: drivers/hid/hid-cp2112.c:793 cp2112_xfer() error: __memcpy() 'data->block[1]' too small (33 vs 255) drivers/hid/hid-cp2112.c:793 cp2112_xfer() error: __memcpy() 'buf' too small (64 vs 255) The 'read_length' variable is provided by 'data->block[0]' which comes from user and it(read_length) can take a value between 0-255. Add an upper bound to 'read_length' variable to prevent a buffer overflow in memcpy().
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.15 and later | 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0 | Patch available | CNA |
- Linux VendorLinux Affected 4.15 and later Fixed in 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.15.1 to before 4.19.256; 4.20 to before 5.4.211; 5.5 to before 5.10.137; 5.11 to before 5.15.61; 5.16 to before 5.18.18; 5.19 to before 5.19.2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.15:-:*:*:*:*:*:* | 4.15 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.15:rc6:*:*:*:*:*:* | 4.15 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.15:rc7:*:*:*:*:*:* | 4.15 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.15:rc8:*:*:*:*:*:* | 4.15 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.15:rc9:*:*:*:*:*:* | 4.15 rc9 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.15.1 to before 4.19.256; 4.20 to before 5.4.211; 5.5 to before 5.10.137; 5.11 to before 5.15.61; 5.16 to before 5.18.18; 5.19 to before 5.19.2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.15:-:*:*:*:*:*:* Versions 4.15 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.15:rc6:*:*:*:*:*:* Versions 4.15 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.15:rc7:*:*:*:*:*:* Versions 4.15 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.15:rc8:*:*:*:*:*:* Versions 4.15 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.15:rc9:*:*:*:*:*:* Versions 4.15 rc9 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.256, 5.4.211, 5.10.137, 5.15.61, 5.18.18, 5.19.2, 6.0
Red Hat 1 advisory
- RHSA-2023:2458 Released 2023-05-09 · Red Hat rating Importantkernel security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-284.11.1.el9_2, kernel-64k-debug-devel-matched-5.14.0-284.11.1.el9_2, kernel-64k-devel-5.14.0-284.11.1.el9_2 +10
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-7.0.0-284.11.1.el9_2, kernel-5.14.0-284.11.1.el9_2, kernel-64k-5.14.0-284.11.1.el9_2 +29
- Red Hat Enterprise Linux CRB (v. 9) kernel-tools-libs-devel-5.14.0-284.11.1.el9_2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:2458 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2023:2458 |
| Red Hat Enterprise Linux CRB (v. 9) | Fixed | RHSA-2023:2458 |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-50156
- 2026-10-03 Alias added: GHSA-gwcc-2364-w9p4
References
Patch 7
- https://git.kernel.org/stable/c/3af7d60e9a6c17d6d41c4341f8020511887d372d
- https://git.kernel.org/stable/c/519ff31a6ddd87aa4905bd9bf3b92e8b88801614
- https://git.kernel.org/stable/c/ebda3d6b004bb6127a66a616524a2de152302ca7
- https://git.kernel.org/stable/c/8489a20ac481b08c0391608d81ed3796d373cfdf
- https://git.kernel.org/stable/c/e7028944e61014ae915e7fb74963d3835f2f761a
- https://git.kernel.org/stable/c/26e427ac85c2b8d0d108cc80b6de34d33e2780c4
- https://git.kernel.org/stable/c/381583845d19cb4bd21c8193449385f3fefa9caf
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-50156 · CVE Program
- CVE-2022-50156 · NVD
- FIRST EPSS
- GHSA-gwcc-2364-w9p4 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-50156 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences