Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400 and CWE-502.
Summary
### Summary The version used of Log4j, the library used for logging by PowerNukkit, is subject to a remote code execution vulnerability via the ldap JNDI parser. It's well detailed at [CVE-2021-44228](https://github.com/advisories/GHSA-jfh8-c2jp-5v3q) and CVE-2021-45105(https://github.com/advisories/GHSA-p6xc-xr62-6r2g). ### Impact Malicious client code could be used to send messages and cause remote code execution on the server. ### Patches PowerNukkit `1.5.2.1` is a patch-release that only updates the Log4j version to `2.17.0` and should be used instead of `1.5.2.0`. All versions prior to `1.5.2.1` are affected and are not patched. ### Workarounds If you can't upgrade, you can use the `-Dlog4j2.formatMsgNoLookups=true` startup argument as remediation, as this prevents the vulnerability from happening. ### References https://github.com/advisories/GHSA-jfh8-c2jp-5v3q https://github.com/advisories/GHSA-p6xc-xr62-6r2g ### For more information If you have any questions or comments about this advisory: * Open an issue in [the PowerNukkit repository](https://github.com/PowerNukkit/PowerNukkit/issues)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | org.powernukkit:powernukkit (Maven) | before 1.5.2.1 | 1.5.2.1 | Patch available | GHSA-3qpm-h9ch-px3c |
- org.powernukkit:powernukkit (Maven) Vendor— Affected before 1.5.2.1 Fixed in 1.5.2.1 Patch available GHSA-3qpm-h9ch-px3c
Remediation
- Fix · GHSA-3qpm-h9ch-px3c org.powernukkit:powernukkit (Maven) Fixed in 1.5.2.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-3qpm-h9ch-px3c
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences