Read the docs
TI-2022-26460 Aliases GHSA-m6w8-fq7v-ph4m

GovernorCompatibilityBravo incorrect ABI encoding may lead to unexpected behavior

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact The `GovernorCompatibilityBravo` module may lead to the creation of governance proposals that execute function calls with incorrect arguments due to bad ABI encoding. This happens if the proposal is created using explicit function signatures, e.g. a proposal to invoke the function `foo(uint256)` is created as `propose([target], [0], ["foo(uint256)"], ["0x00..01"])`. If the function selector is provided as part of the encoded proposal data the issue is not present, e.g. the same proposal is created as `propose([target], [0], ["0x2fbebd3800..01"])`, where `2fbebd38` is the function selector. We've assessed the instances of this contract found on chain, and did not find any occurrence of this bug in the past. Proposal creation through Tally or OpenZeppelin Defender is not affected. The core `Governor` contract on its own is not affected. ### Patches A fix is included in version v4.4.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. ### Workarounds Do not create proposals using explicit function signatures. Instead, use the `propose` function without the `signatures` argument, and create the proposal using the fully ABI-encoded function call including the function selector in the `calldatas` argument as explained above. ### References https://github.com/OpenZeppelin/openzeppelin-contracts/issues/3099 ### Credits This issue was identified and reported by @GeraldHost. ### For more information If you have any questions, comments, or need assistance regarding this advisory, email us at [email protected]. To submit security reports please use [our bug bounty on Immunefi](https://immunefi.com/bounty/openzeppelin/).

Why it matters now

Fix Fixed @openzeppelin/contracts (npm): 4.4.2@openzeppelin/contracts-upgradeable (npm): 4.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@openzeppelin/contracts (npm)4.3.0 to before 4.4.24.4.2Patch availableGHSA-m6w8-fq7v-ph4m
—@openzeppelin/contracts-upgradeable (npm)4.3.0 to before 4.4.24.4.2Patch availableGHSA-m6w8-fq7v-ph4m
  • @openzeppelin/contracts (npm) Vendor— Affected 4.3.0 to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-m6w8-fq7v-ph4m
  • @openzeppelin/contracts-upgradeable (npm) Vendor— Affected 4.3.0 to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-m6w8-fq7v-ph4m

Remediation

  • Fix · GHSA-m6w8-fq7v-ph4m @openzeppelin/contracts (npm) Fixed in 4.4.2 Advisory →
  • Fix · GHSA-m6w8-fq7v-ph4m @openzeppelin/contracts-upgradeable (npm) Fixed in 4.4.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-m6w8-fq7v-ph4m

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences