Read the docs
TI-2022-26464 Aliases GHSA-7v3x-h7r2-34jv

Insufficient Session Expiration in Pterodactyl API

Priority LOW 38CWE-613Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-613.

Summary

### Impact A vulnerability exists in Pterodactyl Panel `<= 1.6.6` that could allow a malicious attacker that compromises an API key to generate an authenticated user session that is not revoked when the API key is deleted, thus allowing the malicious user to remain logged in as the user the key belonged to. It is important to note that **a malicious user must first compromise an existing API key for a user to exploit this issue**. It cannot be exploited by chance, and requires a coordinated attack against an individual account using a known API key. ### Patches This issue has been addressed in the `v1.7.0` release of Pterodactyl Panel. ### Workarounds Those not wishing to upgrade may apply the change below: ```diff diff --git a/app/Http/Middleware/Api/AuthenticateKey.php b/app/Http/Middleware/Api/AuthenticateKey.php index eb25dac6..857bfab2 100644 --- a/app/Http/Middleware/Api/AuthenticateKey.php +++ b/app/Http/Middleware/Api/AuthenticateKey.php @@ -70,7 +70,7 @@ class AuthenticateKey } else { $model = $this->authenticateApiKey($request->bearerToken(), $keyType); - $this->auth->guard()->loginUsingId($model->user_id); + $this->auth->guard()->onceUsingId($model->user_id); } ``` ### For more information If you have any questions or comments about this advisory please reach out to `Tactical Fish#8008` on [Discord](https://discord.gg/pterodactyl) or email `[email protected]`.

Why it matters now

Fix Fixed pterodactyl/panel (Packagist): 1.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—pterodactyl/panel (Packagist)before 1.7.01.7.0Patch availableGHSA-7v3x-h7r2-34jv
  • pterodactyl/panel (Packagist) Vendor— Affected before 1.7.0 Fixed in 1.7.0 Patch available GHSA-7v3x-h7r2-34jv

Remediation

  • Fix · GHSA-7v3x-h7r2-34jv pterodactyl/panel (Packagist) Fixed in 1.7.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-7v3x-h7r2-34jv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences