Read the docs
TI-2022-26474 Aliases GHSA-wcv5-vrvr-3rx2

Integer Overflow or Wraparound in TensorFlow

Priority LOW 38CWE-190Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact The Grappler component of TensorFlow is vulnerable to a denial of service via `CHECK`-failure (assertion failure) in [constant folding](https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/optimizers/constant_folding.cc#L963-L1035): ```cc for (const auto& output_prop : output_props) { const PartialTensorShape output_shape(output_prop.shape()); // ... } ``` The `output_prop` tensor has a shape that is controlled by user input and this can result in triggering one of the `CHECK`s in the `PartialTensorShape` constructor. This is an instance of [TFSA-2021-198](https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md) (CVE-2021-41197). ### Patches We have patched the issue in GitHub commit [be7b286d40bc68cb0b56f702186cc4837d508058](https://github.com/tensorflow/tensorflow/commit/be7b286d40bc68cb0b56f702186cc4837d508058). The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. ### For more information Please consult [our security guide](https://github.com/tensorflow/tensorflow/blob/master/SECURITY.md) for more information regarding the security model and how to contact us with issues and questions.

Why it matters now

Fix Fixed tensorflow (PyPI): 2.5.3, 2.6.3, 2.7.1tensorflow-cpu (PyPI): 2.5.3, 2.6.3, 2.7.1+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—tensorflow (PyPI)before 2.5.32.5.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-cpu (PyPI)before 2.5.32.5.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-cpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-gpu (PyPI)before 2.5.32.5.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-wcv5-vrvr-3rx2
—tensorflow-gpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-wcv5-vrvr-3rx2
  • tensorflow (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-wcv5-vrvr-3rx2
  • tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-wcv5-vrvr-3rx2

Remediation

  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-cpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-cpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-cpu (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-gpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-gpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-wcv5-vrvr-3rx2 tensorflow-gpu (PyPI) Fixed in 2.7.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-wcv5-vrvr-3rx2

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences