Improper Validation of Integrity Check Value in TensorFlow
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact The implementation of [`tf.sparse.split`](https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_split_op.cc#L26-L102) does not fully validate the input arguments. Hence, a malicious user can trigger a denial of service via a segfault or a heap OOB read: ```python import tensorflow as tf data = tf.random.uniform([1, 32, 32], dtype=tf.float32) axis = [1, 2] x = tf.sparse.from_dense(data) result = tf.sparse.split(x,3, axis=axis) ``` The code assumes `axis` is a scalar. This is another instance of [TFSA-2021-190](https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-190.md) (CVE-2021-41206). ### Patches We have patched the issue in GitHub commit [61bf91e768173b001d56923600b40d9a95a04ad5](https://github.com/tensorflow/tensorflow/commit/61bf91e768173b001d56923600b40d9a95a04ad5) (merging [#53695](https://github.com/tensorflow/tensorflow/pull/53695)). The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. ### For more information Please consult [our security guide](https://github.com/tensorflow/tensorflow/blob/master/SECURITY.md) for more information regarding the security model and how to contact us with issues and questions. ### Attribution This vulnerability has been reported externally via a [GitHub issue](https://github.com/tensorflow/tensorflow/issues/53660).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | tensorflow (PyPI) | before 2.5.3 | 2.5.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow (PyPI) | 2.6.0 to before 2.6.3 | 2.6.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow (PyPI) | 2.7.0 to before 2.7.1 | 2.7.1 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-cpu (PyPI) | before 2.5.3 | 2.5.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-cpu (PyPI) | 2.6.0 to before 2.6.3 | 2.6.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-cpu (PyPI) | 2.7.0 to before 2.7.1 | 2.7.1 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-gpu (PyPI) | before 2.5.3 | 2.5.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-gpu (PyPI) | 2.6.0 to before 2.6.3 | 2.6.3 | Patch available | GHSA-43q8-3fv7-pr5x |
| — | tensorflow-gpu (PyPI) | 2.7.0 to before 2.7.1 | 2.7.1 | Patch available | GHSA-43q8-3fv7-pr5x |
- tensorflow (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-cpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-gpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-43q8-3fv7-pr5x
- tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-43q8-3fv7-pr5x
Remediation
- Fix · GHSA-43q8-3fv7-pr5x tensorflow (PyPI) Fixed in 2.5.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow (PyPI) Fixed in 2.6.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow (PyPI) Fixed in 2.7.1 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-cpu (PyPI) Fixed in 2.5.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-cpu (PyPI) Fixed in 2.6.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-cpu (PyPI) Fixed in 2.7.1 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-gpu (PyPI) Fixed in 2.5.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-gpu (PyPI) Fixed in 2.6.3 Advisory →
- Fix · GHSA-43q8-3fv7-pr5x tensorflow-gpu (PyPI) Fixed in 2.7.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-43q8-3fv7-pr5x
References
Other 5
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-43q8-3fv7-pr5x
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pgcq-h79j-2f69
- https://github.com/tensorflow/tensorflow/pull/53695
- https://github.com/tensorflow/tensorflow/commit/61bf91e768173b001d56923600b40d9a95a04ad5
- https://github.com/tensorflow/tensorflow
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences