Read the docs
TI-2022-26490 Aliases GHSA-w4f8-fxq2-j35v

Possible privilege escalation via bash completion script

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

The bash completion script for `fscrypt` through v0.3.2 allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the `fscrypt` bash completion script to complete mountpoint paths. We recommend upgrading to v0.3.3 or above. For more details, see [CVE-2022-25328](https://www.cve.org/CVERecord?id=CVE-2022-25328).

Why it matters now

Fix Fixed github.com/google/fscrypt (Go): 0.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/google/fscrypt (Go)before 0.3.30.3.3Patch availableGHSA-w4f8-fxq2-j35v
  • github.com/google/fscrypt (Go) Vendor— Affected before 0.3.3 Fixed in 0.3.3 Patch available GHSA-w4f8-fxq2-j35v

Remediation

  • Fix · GHSA-w4f8-fxq2-j35v github.com/google/fscrypt (Go) Fixed in 0.3.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w4f8-fxq2-j35v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences