Read the docs
TI-2022-26491 Aliases GHSA-p93v-m2r2-4387

Denial of service via insufficient metadata validation

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

The PAM module for `fscrypt` through v0.3.2 doesn't adequately validate `fscrypt` metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a `fscrypt` metadata file that prevents other users from logging into the system. We recommend upgrading to v0.3.3 or above. For more details, see [CVE-2022-25327](https://www.cve.org/CVERecord?id=CVE-2022-25327).

Why it matters now

Fix Fixed github.com/google/fscrypt (Go): 0.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/google/fscrypt (Go)before 0.3.30.3.3Patch availableGHSA-p93v-m2r2-4387
  • github.com/google/fscrypt (Go) Vendor— Affected before 0.3.3 Fixed in 0.3.3 Patch available GHSA-p93v-m2r2-4387

Remediation

  • Fix · GHSA-p93v-m2r2-4387 github.com/google/fscrypt (Go) Fixed in 0.3.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-p93v-m2r2-4387

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences