Improper Certificate Validation in node-sass affects eZ Platform
Priority LOW 38CWE-295Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-295.
Summary
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
Why it matters now
Fix Fixed ezsystems/ezplatform-admin-ui (Packagist): 1.5.27
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ezsystems/ezplatform-admin-ui (Packagist) | 1.5.0 to before 1.5.27 | 1.5.27 | Patch available | GHSA-6v6p-g8cg-2hgg |
- ezsystems/ezplatform-admin-ui (Packagist) Vendor— Affected 1.5.0 to before 1.5.27 Fixed in 1.5.27 Patch available GHSA-6v6p-g8cg-2hgg
Remediation
- Fix · GHSA-6v6p-g8cg-2hgg ezsystems/ezplatform-admin-ui (Packagist) Fixed in 1.5.27 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-6v6p-g8cg-2hgg
References
Advisory 2
Other 4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences