XSS in various backend modules due to (un)escaping in JS notification module
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
The notification module displaying flash messages unscapes HTML coming from the server, resulting in XSS vulnerabilities with various names and labels of entities (eg. workspace title or media title). This however means you must be a logged in user with respective rights in the first place to leverage the attack vector.
Why it matters now
Fix Fixed neos/neos (Packagist): 5.3.10, 7.0.9, 7.1.7 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | neos/neos (Packagist) | 3.3 to before 5.3.10 | 5.3.10 | Patch available | GHSA-jfxf-4frr-9j3q |
| — | neos/neos (Packagist) | 7.0.0 to before 7.0.9 | 7.0.9 | Patch available | GHSA-jfxf-4frr-9j3q |
| — | neos/neos (Packagist) | 7.1.0 to before 7.1.7 | 7.1.7 | Patch available | GHSA-jfxf-4frr-9j3q |
| — | neos/neos (Packagist) | 7.2.0 to before 7.2.6 | 7.2.6 | Patch available | GHSA-jfxf-4frr-9j3q |
| — | neos/neos (Packagist) | 7.3.0 to before 7.3.4 | 7.3.4 | Patch available | GHSA-jfxf-4frr-9j3q |
| — | neos/neos (Packagist) | 8.0.0 to before 8.0.2 | 8.0.2 | Patch available | GHSA-jfxf-4frr-9j3q |
- neos/neos (Packagist) Vendor— Affected 3.3 to before 5.3.10 Fixed in 5.3.10 Patch available GHSA-jfxf-4frr-9j3q
- neos/neos (Packagist) Vendor— Affected 7.0.0 to before 7.0.9 Fixed in 7.0.9 Patch available GHSA-jfxf-4frr-9j3q
- neos/neos (Packagist) Vendor— Affected 7.1.0 to before 7.1.7 Fixed in 7.1.7 Patch available GHSA-jfxf-4frr-9j3q
- neos/neos (Packagist) Vendor— Affected 7.2.0 to before 7.2.6 Fixed in 7.2.6 Patch available GHSA-jfxf-4frr-9j3q
- neos/neos (Packagist) Vendor— Affected 7.3.0 to before 7.3.4 Fixed in 7.3.4 Patch available GHSA-jfxf-4frr-9j3q
- neos/neos (Packagist) Vendor— Affected 8.0.0 to before 8.0.2 Fixed in 8.0.2 Patch available GHSA-jfxf-4frr-9j3q
Remediation
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 5.3.10 Advisory →
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 7.0.9 Advisory →
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 7.1.7 Advisory →
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 7.2.6 Advisory →
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 7.3.4 Advisory →
- Fix · GHSA-jfxf-4frr-9j3q neos/neos (Packagist) Fixed in 8.0.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-jfxf-4frr-9j3q
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences