Ghost vulnerable to remote code execution in locale setting change
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact A [vulnerability](https://www.cve.org/CVERecord?id=CVE-2022-24785) in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor. ### Patches Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible. ### Workarounds Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution. As a workaround, if for any reason you cannot update your Ghost instance, you can block the `POST /ghost/api/admin/settings/` endpoint, which will also disable updating settings for your site. ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected]) ### Credits * devx00 - https://twitter.com/devx00
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ghost (npm) | before 4.48.2 | 4.48.2 | Patch available | GHSA-7v28-g2pq-ggg8 |
| — | ghost (npm) | 5.0.0 to before 5.2.3 | 5.2.3 | Patch available | GHSA-7v28-g2pq-ggg8 |
- ghost (npm) Vendor— Affected before 4.48.2 Fixed in 4.48.2 Patch available GHSA-7v28-g2pq-ggg8
- ghost (npm) Vendor— Affected 5.0.0 to before 5.2.3 Fixed in 5.2.3 Patch available GHSA-7v28-g2pq-ggg8
Remediation
- Fix · GHSA-7v28-g2pq-ggg8 ghost (npm) Fixed in 4.48.2 Advisory →
- Fix · GHSA-7v28-g2pq-ggg8 ghost (npm) Fixed in 5.2.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-7v28-g2pq-ggg8
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences