Read the docs
TI-2022-26607 Aliases GHSA-q37h-jhf3-85cj

Bypass of CMS Safe Mode Security Feature

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact Authenticated users with permissions to create or modify theme template objects through the backend "CMS" editor can exploit this vulnerability to bypass the `cms.enableSafeMode` security feature if enabled (disables modification of PHP code through the web interface when enabled). This is only an issue for Winter CMS instances that rely on the Safe Mode security feature to prevent privileged users from modifying the PHP code of CMS theme template objects through the web interface. CVSS v3.1 Vector: [AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C](https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C&version=3.1) ### Patches Issue has been fixed in v1.0.475, v1.1.9, & v1.2. ### Workarounds Apply https://github.com/wintercms/storm/commit/03eb5ce3f2a271670574802b914f7bcaf07663c1 manually if unable to upgrade to v1.0.475, v1.1.9, or v1.2.0. ### References See https://github.com/octobercms/october/security/advisories/GHSA-79jw-2f46-wv22/. Credit to [David Miller](https://github.com/cydave) for reporting the issue. ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed wintercms/winter (Packagist): 1.0.475, 1.1.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—wintercms/winter (Packagist)before 1.0.4751.0.475Patch availableGHSA-q37h-jhf3-85cj
—wintercms/winter (Packagist)1.1.0 to before 1.1.91.1.9Patch availableGHSA-q37h-jhf3-85cj
  • wintercms/winter (Packagist) Vendor— Affected before 1.0.475 Fixed in 1.0.475 Patch available GHSA-q37h-jhf3-85cj
  • wintercms/winter (Packagist) Vendor— Affected 1.1.0 to before 1.1.9 Fixed in 1.1.9 Patch available GHSA-q37h-jhf3-85cj

Remediation

  • Fix · GHSA-q37h-jhf3-85cj wintercms/winter (Packagist) Fixed in 1.0.475 Advisory →
  • Fix · GHSA-q37h-jhf3-85cj wintercms/winter (Packagist) Fixed in 1.1.9 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-q37h-jhf3-85cj

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences