Read the docs
TI-2022-26613 Aliases GHSA-9x8m-2xpf-crp3

Scrapy before 2.6.2 and 1.8.3 vulnerable to one proxy sending credentials to another

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact When the [built-in HTTP proxy downloader middleware](https://docs.scrapy.org/en/2.6/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpproxy) processes a request with `proxy` metadata, and that `proxy` metadata includes proxy credentials, the built-in HTTP proxy downloader middleware sets the `Proxy-Authentication` header, but only if that header is not already set. There are third-party proxy-rotation downloader middlewares that set different `proxy` metadata every time they process a request. Because of request retries and redirects, the same request can be processed by downloader middlewares more than once, including both the built-in HTTP proxy downloader middleware and any third-party proxy-rotation downloader middleware. These third-party proxy-rotation downloader middlewares could change the `proxy` metadata of a request to a new value, but fail to remove the `Proxy-Authentication` header from the previous value of the `proxy` metadata, causing the credentials of one proxy to be leaked to a different proxy. If you rotate proxies from different proxy providers, and any of those proxies requires credentials, you are affected, unless you are handling proxy rotation as described under **Workarounds** below. If you use a third-party downloader middleware for proxy rotation, the same applies to that downloader middleware, and installing a patched version of Scrapy may not be enough; patching that downloader middlware may be necessary as well. ### Patches Upgrade to Scrapy 2.6.2. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.6.2 is not an option, you may upgrade to Scrapy 1.8.3 instead. ### Workarounds If you cannot upgrade, make sure that any code that changes the value of the `proxy` request meta also removes the `Proxy-Authorization` header from the request if present. ### For more information If you have any questions or comments about this advisory: * [Open an issue](https://github.com/scrapy/scrapy/issues) * [Email us](mailto:[email protected])

Why it matters now

Fix Fixed scrapy (PyPI): 1.8.3, 2.6.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—scrapy (PyPI)before 1.8.31.8.3Patch availableGHSA-9x8m-2xpf-crp3
—scrapy (PyPI)2.0.0 to before 2.6.22.6.2Patch availableGHSA-9x8m-2xpf-crp3
  • scrapy (PyPI) Vendor— Affected before 1.8.3 Fixed in 1.8.3 Patch available GHSA-9x8m-2xpf-crp3
  • scrapy (PyPI) Vendor— Affected 2.0.0 to before 2.6.2 Fixed in 2.6.2 Patch available GHSA-9x8m-2xpf-crp3

Remediation

  • Fix · GHSA-9x8m-2xpf-crp3 scrapy (PyPI) Fixed in 1.8.3 Advisory →
  • Fix · GHSA-9x8m-2xpf-crp3 scrapy (PyPI) Fixed in 2.6.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9x8m-2xpf-crp3

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences