Read the docs
TI-2022-26633 Aliases GHSA-9q5j-jm53-v7vr

lz4-sys vulnerable to memory corruption via issue in liblz4

Priority LOW 38CWE-190Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

lz4-sys up to v1.9.3 bundles a version of liblz4 that is vulnerable to [CVE-2021-3520](https://nvd.nist.gov/vuln/detail/CVE-2021-3520). Attackers could craft a payload that triggers an integer overflow upon decompression, causing an out-of-bounds write. The flaw has been corrected in version v1.9.4 of liblz4, which is included in lz4-sys 1.9.4.

Why it matters now

Fix Fixed lz4-sys (crates.io): 1.9.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—lz4-sys (crates.io)before 1.9.41.9.4Patch availableGHSA-9q5j-jm53-v7vr
  • lz4-sys (crates.io) Vendor— Affected before 1.9.4 Fixed in 1.9.4 Patch available GHSA-9q5j-jm53-v7vr

Remediation

  • Fix · GHSA-9q5j-jm53-v7vr lz4-sys (crates.io) Fixed in 1.9.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9q5j-jm53-v7vr

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences