Pageflow vulnerable to sensitive user data extraction via Ransack query injection
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact The attack allows extracting sensitive properties of database objects that are associated with users or entries belonging to an account that the attacker has access to. Pageflow uses the `ActiveAdmin` Ruby library to provide some management features to its users. `ActiveAdmin` relies on the `Ransack` library to implement search functionality. In its default configuration, `Ransack` will allow for query conditions based on properties of associated database objects [1]. The `*_starts_with`, `*_ends_with` or `*_contains` search matchers [2] can then be abused to exfiltrate sensitive string values of associated database objects via character-by-character brute-force. [1] https://activerecord-hackery.github.io/ransack/going-further/associations/ [2] https://activerecord-hackery.github.io/ransack/getting-started/search-matches/ ### Mitigation Upgrade to version 15.7.1 or 14.5.2 of the `pageflow` gem. ### For more information If you have any questions or comments about this advisory email us at info(at)codevise.de ### Credits [Positive Security](https://positive.security/)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pageflow (RubyGems) | before 14.5.2 | 14.5.2 | Patch available | GHSA-wrrw-crp8-979q |
| — | pageflow (RubyGems) | 15.0.0 to before 15.7.1 | 15.7.1 | Patch available | GHSA-wrrw-crp8-979q |
- pageflow (RubyGems) Vendor— Affected before 14.5.2 Fixed in 14.5.2 Patch available GHSA-wrrw-crp8-979q
- pageflow (RubyGems) Vendor— Affected 15.0.0 to before 15.7.1 Fixed in 15.7.1 Patch available GHSA-wrrw-crp8-979q
Remediation
- Fix · GHSA-wrrw-crp8-979q pageflow (RubyGems) Fixed in 14.5.2 Advisory →
- Fix · GHSA-wrrw-crp8-979q pageflow (RubyGems) Fixed in 15.7.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-wrrw-crp8-979q
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences