Read the docs
TI-2022-26637 Aliases GHSA-qcqv-38jg-2r43

Pageflow vulnerable to insecure direct object reference in membership update endpoint

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact Pageflow has a membership edit feature which allows users to edit the roles of user memberships associated with an account that they have the `manager` role to (including their own). While the `Entity` dropdown select field is greyed out in the UI, an attacker can use tools which allow sending arbitrary HTTP request to craft a request to the `/admin/users/{user_id}/memberships/{membership_id}` endpoint containing an additional `membership[entity_id]` parameter. This parameter is honored when the membership is updated, allowing an attacker to update the membership object associated with their own account (with `manager` role) to be associated with a different attacker-chosen account instead. Since `account_id`s are enumerable, an attacker can compromise all accounts present on the platform. ### Mitigation Upgrade to version 15.7.1 or 14.5.2 of the `pageflow` gem. ### For more information If you have any questions or comments about this advisory email us at info(at)codevise.de ### Credits [Positive Security](https://positive.security/)

Why it matters now

Fix Fixed pageflow (RubyGems): 14.5.2, 15.7.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—pageflow (RubyGems)before 14.5.214.5.2Patch availableGHSA-qcqv-38jg-2r43
—pageflow (RubyGems)15.0.0 to before 15.7.115.7.1Patch availableGHSA-qcqv-38jg-2r43
  • pageflow (RubyGems) Vendor— Affected before 14.5.2 Fixed in 14.5.2 Patch available GHSA-qcqv-38jg-2r43
  • pageflow (RubyGems) Vendor— Affected 15.0.0 to before 15.7.1 Fixed in 15.7.1 Patch available GHSA-qcqv-38jg-2r43

Remediation

  • Fix · GHSA-qcqv-38jg-2r43 pageflow (RubyGems) Fixed in 14.5.2 Advisory →
  • Fix · GHSA-qcqv-38jg-2r43 pageflow (RubyGems) Fixed in 15.7.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qcqv-38jg-2r43

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences