Read the docs
TI-2022-26655 Aliases GHSA-mgvv-5mxp-xq67

SQLite3 addresses vulnerability in packaged version of libsqlite

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Summary The rubygem sqlite3 v1.5.1 upgrades the packaged version of libsqlite from v3.39.3 to [v3.39.4](https://sqlite.org/releaselog/3_39_4.html). libsqlite v3.39.4 addresses a vulnerability described as follows in the release notification: > Version 3.39.4 is a minimal patch against the prior release that addresses issues found since the > prior release. In particular, a potential vulnerability in the FTS3 extension has been fixed, so > this should be considered a security update. > > In order to exploit the vulnerability, an attacker must have full SQL access and must be able to > construct a corrupt database with over 2GB of FTS3 content. The problem arises from a 32-bit > signed integer overflow. This vulnerability has not been assigned a CVE and does not have a severity declared. Please note that this advisory only applies to the sqlite3 gem v1.5.0, and only if the packaged libsqlite is being used. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention to your distro's libsqlite release announcements. ### Mitigation Upgrade to the rubygem sqlite3 v1.5.1 or later. Users who are unable to upgrade the sqlite3 gem may also choose a more complicated mitigation: compile and link sqlite3 against external libsqlite >= 3.39.4 which will also address these same issues. ### References - Upstream release notes: https://sqlite.org/releaselog/3_39_4.html - Instructions for compiling against system libraries: https://github.com/sparklemotion/sqlite3-ruby

Why it matters now

Fix Fixed sqlite3 (RubyGems): 1.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—sqlite3 (RubyGems)1.5.0 to before 1.5.11.5.1Patch availableGHSA-mgvv-5mxp-xq67
  • sqlite3 (RubyGems) Vendor— Affected 1.5.0 to before 1.5.1 Fixed in 1.5.1 Patch available GHSA-mgvv-5mxp-xq67

Remediation

  • Fix · GHSA-mgvv-5mxp-xq67 sqlite3 (RubyGems) Fixed in 1.5.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-mgvv-5mxp-xq67

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences