Read the docs
TI-2022-26687 Aliases GHSA-gpv5-rp6w-58r8

Remote code execution vulnerability in dependency System.Drawing.Common

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28. The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET. ### Patches _Has the problem been patched? What versions should users upgrade to?_ This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ You might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself. ### References _Are there any links users can visit to find out more?_ Original issue: https://github.com/akkadotnet/akka.net/issues/6226 MSFT advisory: https://github.com/advisories/GHSA-ghhp-997w-qr28 ### For more information If you have any questions or comments about this advisory: * Open an issue in [the Akka.NET repository](https://github.com/akkadotnet/akka.net/issues/new) * Contact us on [the Akka.NET Discord](https://discord.gg/GSCfPwhbWP)

Why it matters now

Fix Fixed Akka (NuGet): 1.4.46, 1.5.0-alpha3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Akka (NuGet)before 1.4.461.4.46Patch availableGHSA-gpv5-rp6w-58r8
—Akka (NuGet)1.5.0-alpha1 to before 1.5.0-alpha31.5.0-alpha3Patch availableGHSA-gpv5-rp6w-58r8
  • Akka (NuGet) Vendor— Affected before 1.4.46 Fixed in 1.4.46 Patch available GHSA-gpv5-rp6w-58r8
  • Akka (NuGet) Vendor— Affected 1.5.0-alpha1 to before 1.5.0-alpha3 Fixed in 1.5.0-alpha3 Patch available GHSA-gpv5-rp6w-58r8

Remediation

  • Fix · GHSA-gpv5-rp6w-58r8 Akka (NuGet) Fixed in 1.4.46 Advisory →
  • Fix · GHSA-gpv5-rp6w-58r8 Akka (NuGet) Fixed in 1.5.0-alpha3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-gpv5-rp6w-58r8

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences