Read the docs
TI-2022-26688 Aliases GHSA-qq6h-5g6j-q3cm

sweetalert2 v11.4.9 and above contains hidden functionality

Priority LOW 38CWE-912Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

`sweetalert2` versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8. ### Workaround Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.

Why it matters now

Fix Fixed sweetalert2 (npm): 11.22.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—sweetalert2 (npm)11.4.9 to before 11.22.411.22.4Patch availableGHSA-qq6h-5g6j-q3cm
  • sweetalert2 (npm) Vendor— Affected 11.4.9 to before 11.22.4 Fixed in 11.22.4 Patch available GHSA-qq6h-5g6j-q3cm

Remediation

  • Fix · GHSA-qq6h-5g6j-q3cm sweetalert2 (npm) Fixed in 11.22.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qq6h-5g6j-q3cm

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences