sweetalert2 v10.16.10 and above contains hidden functionality
Priority LOW 38CWE-912Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
`sweetalert2` versions 10.16.10 and up until 11.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 10.0.0 - 10.16.9. ### Workaround Use a version 10.0.0 - 10.16.9 of the package until the maintainer releases a fix.
Why it matters now
Fix Fixed sweetalert2 (npm): 11.22.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | sweetalert2 (npm) | 10.16.10 to before 11.22.4 | 11.22.4 | Patch available | GHSA-457r-cqc8-9vj9 |
- sweetalert2 (npm) Vendor— Affected 10.16.10 to before 11.22.4 Fixed in 11.22.4 Patch available GHSA-457r-cqc8-9vj9
Remediation
- Fix · GHSA-457r-cqc8-9vj9 sweetalert2 (npm) Fixed in 11.22.4 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-457r-cqc8-9vj9
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences