sweetalert2 v9.17.4 and above contains hidden functionality
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
`sweetalert2` versions 9.17.4 and up until 10.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 9.0.0 - 9.17.3. ### Workaround Users who are unable to update to the fixed version (11.22.4) can use package versions 9.0.0-9.17.3, as they do not contain the hidden functionality.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | sweetalert2 (npm) | 9.17.4 to before 11.22.4 | 11.22.4 | Patch available | GHSA-pg98-6v7f-2xfv |
- sweetalert2 (npm) Vendor— Affected 9.17.4 to before 11.22.4 Fixed in 11.22.4 Patch available GHSA-pg98-6v7f-2xfv
Remediation
- Fix · GHSA-pg98-6v7f-2xfv sweetalert2 (npm) Fixed in 11.22.4 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-pg98-6v7f-2xfv
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences