Read the docs
TI-2022-26694 Aliases GHSA-755v-r4x4-qf7m

Stored Cross-Site Scripting (XSS) in Keycloak via groups dropdown

Priority LOW 38CWE-80Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-80.

Summary

### Summary A Stored XSS vulnerability was reported in the Keycloak Security mailing list, affecting all the versions of Keycloak, including the latest release (16.0.1). The vulnerability allows a privileged attacker to execute malicious scripts in the admin console, abusing of the groups' dropdown functionality. ### Impact Successful attacks of this vulnerability can result a privileged attacker to load a XSS script, and steal data from other users. The impact can be considered moderate to low, considering privileged credentials are required. ### References - Please refer to the Keycloak Security mailing list for more information.

Why it matters now

Fix Fixed org.keycloak:keycloak-core (Maven): 20.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—org.keycloak:keycloak-core (Maven)before 20.0.020.0.0Patch availableGHSA-755v-r4x4-qf7m
  • org.keycloak:keycloak-core (Maven) Vendor— Affected before 20.0.0 Fixed in 20.0.0 Patch available GHSA-755v-r4x4-qf7m

Remediation

  • Fix · GHSA-755v-r4x4-qf7m org.keycloak:keycloak-core (Maven) Fixed in 20.0.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-755v-r4x4-qf7m

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences