Read the docs
TI-2022-26704 Aliases GHSA-9h6h-9g78-86f7

Yapscan's report receiver server vulnerable to path traversal and log injection

Priority LOW 38CWE-117Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact If you make use of the **report receiver server** (experimental), a client may be able to forge requests such that arbitrary files on the host can be overwritten (subject to permissions of the yapscan server), leading to loss of data. This is particularly problematic if you do not authenticate clients and/or run the server with elevated permissions. ### Patches Vulnerable versions: - v0.18.0 - v0.19.0 (unreleased) This problem is patched in version v0.19.1 ### Workarounds Update to the newer version is highly encouraged! Measures to reduce the risk of this include authenticating clients (see `--client-ca` flag) and containerization of the yapscan server. ### References The tracking issue is #35. There you can find the commits, fixing the issue.

Why it matters now

Fix Fixed github.com/fkie-cad/yapscan (Go): 0.19.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/fkie-cad/yapscan (Go)0.18.0 to before 0.19.10.19.1Patch availableGHSA-9h6h-9g78-86f7
  • github.com/fkie-cad/yapscan (Go) Vendor— Affected 0.18.0 to before 0.19.1 Fixed in 0.19.1 Patch available GHSA-9h6h-9g78-86f7

Remediation

  • Fix · GHSA-9h6h-9g78-86f7 github.com/fkie-cad/yapscan (Go) Fixed in 0.19.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9h6h-9g78-86f7

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences