WP Social Widget < 2.2.4 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP Social Widget WordPress plugin before 2.2.4 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00534 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Social Widget (Unknown): 2.2.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Social Widget | before 2.2.4 | 2.2.4 | Patch available | CNA |
- WP Social Widget VendorUnknown Affected before 2.2.4 Fixed in 2.2.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:catchsquare:wp_social_widget:*:*:*:*:*:wordpress:*:* | before 2.2.4 | Vulnerable | catchsquare |
- cpe:2.3:a:catchsquare:wp_social_widget:*:*:*:*:*:wordpress:*:* Versions before 2.2.4 Vulnerable ·catchsquare
Remediation
- Fix · CNA WP Social Widget (Unknown) Fixed in 2.2.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0074
- 2026-10-03 Alias added: GHSA-4cfp-2523-96q2
References
More catchsquare Wp Social Widget vulnerabilities
- TI-2025-21885 WordPress WP Social Widget plugin <= 2.2.7 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-18044 WordPress WP Social Widget plugin <= 2.2.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-35833 WordPress WP Social Widget Plugin <= 2.3.1 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-31354 WordPress WP Social Widget plugin <= 2.3 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0074 · CVE Program
- CVE-2023-0074 · NVD
- FIRST EPSS
- GHSA-4cfp-2523-96q2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences