Post Grid, Post Carousel, & List Category Posts < 2.4.19 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid, Post Carousel, & List Category Posts WordPress plugin before 2.4.19 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Post Grid, Post Carousel, & List Category Posts (Unknown): 2.4.19
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Grid, Post Carousel, & List Category Posts | before 2.4.19 | 2.4.19 | Patch available | CNA |
- Post Grid, Post Carousel, & List Category Posts VendorUnknown Affected before 2.4.19 Fixed in 2.4.19 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shapedplugin:smart_post_show:*:*:*:*:*:wordpress:*:* | before 2.4.19 | Vulnerable | shapedplugin |
- cpe:2.3:a:shapedplugin:smart_post_show:*:*:*:*:*:wordpress:*:* Versions before 2.4.19 Vulnerable ·shapedplugin
Remediation
- Fix · CNA Post Grid, Post Carousel, & List Category Posts (Unknown) Fixed in 2.4.19
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0097
- 2026-10-03 Alias added: GHSA-8hw8-3xpp-fr77
References
More shapedplugin Smart Post Show vulnerabilities
- TI-2024-07594 Smart Post Show <= 3.0.0 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-03728 Post Grid, Post Carousel, & List Category Posts < 2.4.28 - Editor+ Stored XSS CVSS 3.1LOW 3.5
Sources
- CVE-2023-0097 · CVE Program
- CVE-2023-0097 · NVD
- FIRST EPSS
- GHSA-8hw8-3xpp-fr77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences