Read the docs
TI-2023-00172 Aliases CVE-2023-0178GHSA-83hr-hwqh-94w5

Annual Archive < 1.6.0 - Contributor+ Stored XSS

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Annual Archive WordPress plugin before 1.6.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00573 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Annual Archive (Unknown): 1.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAnnual Archivebefore 1.6.01.6.0Patch availableCNA
  • Annual Archive VendorUnknown Affected before 1.6.0 Fixed in 1.6.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:twinpictures:annual_archive:*:*:*:*:*:wordpress:*:*before 1.6.0VulnerableTwinpictures
  • cpe:2.3:a:twinpictures:annual_archive:*:*:*:*:*:wordpress:*:* Versions before 1.6.0 Vulnerable ·Twinpictures

Remediation

  • Fix · CNA Annual Archive (Unknown) Fixed in 1.6.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0178
  2. 2026-10-03 Alias added: GHSA-83hr-hwqh-94w5

References

  • TI-2023-27251 WordPress Annual Archive Plugin <= 1.6.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources