Pinpoint Booking System < 2.9.9.2.9 - Subscriber+ SQLi
Priority HIGH 73Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Pinpoint Booking System WordPress plugin before 2.9.9.2.9 does not validate and escape one of its shortcode attributes before using it in a SQL statement, which could allow any authenticated users, such as subscriber to perform SQL Injection attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00937 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Pinpoint Booking System (Unknown): 2.9.9.2.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Pinpoint Booking System | before 2.9.9.2.9 | 2.9.9.2.9 | Patch available | CNA |
- Pinpoint Booking System VendorUnknown Affected before 2.9.9.2.9 Fixed in 2.9.9.2.9 Patch available CNA
Remediation
- Fix · CNA Pinpoint Booking System (Unknown) Fixed in 2.9.9.2.9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0220
- 2026-10-03 Alias added: GHSA-3wg8-6w7g-gg2j
References
More Pinpoint Booking System vulnerabilities
- TI-2024-03391 Pinpoint Booking System < 2.9.9.4.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2015-07837 The booking-system plugin before 2.1 for WordPress has DOPBSPBackEndTranslation::display… CVSS 3.1HIGH 8.8
- TI-2024-06585 Pinpoint Booking System <= 2.9.9.5.0- Authenticated (Subscriber+) SQL Injection CVSS 3.1HIGH 8.8
- TI-2023-24260 WordPress Pinpoint Booking System Plugin <= 2.9.9.4.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-12279 Pinpoint Booking System – #1 WordPress Booking Plugin <= 2.9.9.5.4 - Authenticated (Subscriber+) SQL Injection CVSS 3.1MEDIUM 6.5
- TI-2023-10534 WordPress Pinpoint Booking System Plugin <= 2.9.9.2.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-0220 · CVE Program
- CVE-2023-0220 · NVD
- FIRST EPSS
- GHSA-3wg8-6w7g-gg2j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences