ShopLentor < 2.5.4 - PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The ShopLentor WordPress plugin before 2.5.4 unserializes user input from cookies in order to track viewed products and user data, which could lead to PHP Object Injection.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | ShopLentor | before 2.5.4 | 2.5.4 | Patch available | CNA |
- ShopLentor VendorUnknown Affected before 2.5.4 Fixed in 2.5.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasthemes:shoplentor:*:*:*:*:*:wordpress:*:* | before 2.5.4 | Vulnerable | devitemsllc |
- cpe:2.3:a:hasthemes:shoplentor:*:*:*:*:*:wordpress:*:* Versions before 2.5.4 Vulnerable ·devitemsllc
Remediation
- Fix · CNA ShopLentor (Unknown) Fixed in 2.5.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
ShopLentor 2.5.4
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-00221 ShopLentor < 2.5.4 - Contributor+ Stored XSSPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0232
- 2026-10-03 Alias added: GHSA-hp6x-rrx2-386m
References
More devitemsllc Shoplentor vulnerabilities
- TI-2023-00221 ShopLentor < 2.5.4 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2025-11464 ShopLentor <= 3.2.5 - Unauthenticated Local PHP File Inclusion via 'load_template' CVSS 3.1CRITICAL 9.8
- TI-2025-03326 Server-side request forgery in devitemsllc ShopLentor – All-in-One WooCommerce Growth &… CVSS 3.1MEDIUM 6.5
- TI-2024-04252 ShopLentor <= 2.8.8 - Missing Authorization to WordPress Option Modification CVSS 3.1HIGH 7.1
- TI-2024-08848 ShopLentor <= 2.9.8 - Authenticated (Contributor+) Sensitive Information Exposure via WL: FAQ Widget Elementor Template CVSS 3.1MEDIUM 6.5
- TI-2024-05141 Cross-site scripting in devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store… CVSS 3.1MEDIUM 6.4
Sources
- CVE-2023-0232 · CVE Program
- CVE-2023-0232 · NVD
- FIRST EPSS
- GHSA-hp6x-rrx2-386m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences