Qemu: lsi53c895a: dma reentrancy issue leads to stack overflow
Priority LOW 26CWE-121Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-121 and the CVSS impact.
Summary
A vulnerability in the lsi53c895a device affects the latest version of qemu. A DMA-MMIO reentrancy problem may lead to memory corruption bugs like stack overflow or use-after-free.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00253 16th percentileScored 2026-11-07
Fix Fixed qemu: 8.1.0-rc0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | qemu | — | 8.1.0-rc0 | Patch available | CNA |
- qemu Vendor— Affected — Fixed in 8.1.0-rc0 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | 7.2.0 to before 7.2.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:-:*:*:*:*:*:* | 8.0.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:rc0:*:*:*:*:*:* | 8.0.0 rc0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:rc1:*:*:*:*:*:* | 8.0.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:rc2:*:*:*:*:*:* | 8.0.0 rc2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:rc3:*:*:*:*:*:* | 8.0.0 rc3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:8.0.0:rc4:*:*:*:*:*:* | 8.0.0 rc4 | Vulnerable | QEMU |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions 7.2.0 to before 7.2.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:-:*:*:*:*:*:* Versions 8.0.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:rc0:*:*:*:*:*:* Versions 8.0.0 rc0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:rc1:*:*:*:*:*:* Versions 8.0.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:rc2:*:*:*:*:*:* Versions 8.0.0 rc2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:rc3:*:*:*:*:*:* Versions 8.0.0 rc3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:8.0.0:rc4:*:*:*:*:*:* Versions 8.0.0 rc4 Vulnerable ·QEMU
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA qemu Fixed in 8.1.0-rc0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 6 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 8 Advanced Virtualization
- Red Hat Enterprise Linux 9
- Red Hat OpenStack Platform 13 (Queens)
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0330
- 2026-10-03 Alias added: GHSA-fj3c-gq42-693w
References
Sources
- CVE-2023-0330 · CVE Program
- CVE-2023-0330 · NVD
- FIRST EPSS
- GHSA-fj3c-gq42-693w · GitHub Advisory Database · CC BY 4.0
- CVE-2023-0330 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences