Scheduled Announcements Widget < 1.0 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Scheduled Announcements Widget WordPress plugin before 1.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00444 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Scheduled Announcements Widget (Unknown): 1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Scheduled Announcements Widget | before 1.0 | 1.0 | Patch available | CNA |
- Scheduled Announcements Widget VendorUnknown Affected before 1.0 Fixed in 1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nlb-creations:scheduled_announcements_widget:*:*:*:*:*:wordpress:*:* | before 1.0 | Vulnerable | Nlb-creations |
- cpe:2.3:a:nlb-creations:scheduled_announcements_widget:*:*:*:*:*:wordpress:*:* Versions before 1.0 Vulnerable ·Nlb-creations
Remediation
- Fix · CNA Scheduled Announcements Widget (Unknown) Fixed in 1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0363
- 2026-10-03 Alias added: GHSA-7hpp-vhg4-3j5w
References
Sources
- CVE-2023-0363 · CVE Program
- CVE-2023-0363 · NVD
- FIRST EPSS
- GHSA-7hpp-vhg4-3j5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences