An issue has been discovered in GitLab affecting all versions starting from 8.1 to…
Priority MEDIUM 54Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An issue has been discovered in GitLab affecting all versions starting from 8.1 to 15.8.5, and from 15.9 to 15.9.4, and from 15.10 to 15.10.1. It was possible to add a branch with an ambiguous name that could be used to social engineer users.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00683 52nd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 15.8.5, 15.9.4, 15.10.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 8.1 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 | 15.8.5, 15.9.4, 15.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 8.1 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 Fixed in 15.8.5, 15.9.4, 15.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 8.1.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 8.1.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* | 15.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* | 15.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 8.1.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 8.1.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* Versions 15.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* Versions 15.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.8.5, 15.9.4, 15.10.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0450
- 2026-10-03 Alias added: GHSA-g8xq-pp9p-qgx8
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-0450 · CVE Program
- CVE-2023-0450 · NVD
- FIRST EPSS
- GHSA-g8xq-pp9p-qgx8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences