Excessive Resource Usage Verifying X.509 Policy Constraints
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 9 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-295.
Summary
A security vulnerability has been identified in all supported versions of OpenSSL related to the verification of X.509 certificate chains that include policy constraints. Attackers may be able to exploit this vulnerability by creating a malicious certificate chain that triggers exponential use of computational resources, leading to a denial-of-service (DoS) attack on affected systems. Policy processing is disabled by default but can be enabled by passing the `-policy' argument to the command line utilities or by calling the `X509_VERIFY_PARAM_set1_policies()' function.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenSSL | OpenSSL | 3.1.0 to before 3.1.1; 3.0.0 to before 3.0.9; 1.1.1 to before 1.1.1u; 1.0.2 to before 1.0.2zh | 3.1.1, 3.0.9, 1.1.1u, 1.0.2zh | Patch available | CNA |
- OpenSSL VendorOpenSSL Affected 3.1.0 to before 3.1.1; 3.0.0 to before 3.0.9; 1.1.1 to before 1.1.1u; 1.0.2 to before 1.0.2zh Fixed in 3.1.1, 3.0.9, 1.1.1u, 1.0.2zh Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* | 1.0.2 to before 1.0.2zh; 1.1.1 to before 1.1.1u; 3.0.0 to before 3.0.9; 3.1.0 to before 3.1.1 | Vulnerable | OpenSSL |
- cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* Versions 1.0.2 to before 1.0.2zh; 1.1.1 to before 1.1.1u; 3.0.0 to before 3.0.9; 3.1.0 to before 3.1.1 Vulnerable ·OpenSSL
Remediation
- Fix · CNA OpenSSL (OpenSSL) Fixed in 3.1.1, 3.0.9, 1.1.1u, 1.0.2zh
Red Hat 5 advisories
- RHSA-2023:7626 Released 2023-12-07 · Red Hat rating ImportantRed Hat JBoss Core Services Apache HTTP Server 2.4.57 SP2 security update
- Red Hat JBoss Core Services
- RHSA-2023:7625 Released 2023-12-07 · Red Hat rating ImportantRed Hat JBoss Core Services Apache HTTP Server 2.4.57 SP2 security update
- Red Hat JBoss Core Services on RHEL 7 Server jbcs-httpd24-curl-8.4.0-2.el7jbcs, jbcs-httpd24-libcurl-8.4.0-2.el7jbcs, jbcs-httpd24-libcurl-devel-8.4.0-2.el7jbcs +8
- Red Hat JBoss Core Services on RHEL 8 jbcs-httpd24-curl-8.4.0-2.el8jbcs, jbcs-httpd24-libcurl-8.4.0-2.el8jbcs, jbcs-httpd24-libcurl-devel-8.4.0-2.el8jbcs +8
- RHSA-2023:7623 Released 2023-12-07 · Red Hat rating ModerateRed Hat JBoss Web Server 5.7.7 release and security update
- Red Hat JBoss Web Server 5
Show 2 more Red Hat advisories
- RHSA-2023:7622 Released 2023-12-07 · Red Hat rating ModerateRed Hat JBoss Web Server 5.7.7 release and security update
- Red Hat JBoss Web Server 5.7 for RHEL 7 Server jws5-tomcat-9.0.62-19.redhat_00017.1.el7jws, jws5-tomcat-admin-webapps-9.0.62-19.redhat_00017.1.el7jws, jws5-tomcat-docs-webapp-9.0.62-19.redhat_00017.1.el7jws +10
- Red Hat JBoss Web Server 5.7 for RHEL 8 jws5-tomcat-9.0.62-19.redhat_00017.1.el8jws, jws5-tomcat-admin-webapps-9.0.62-19.redhat_00017.1.el8jws, jws5-tomcat-docs-webapp-9.0.62-19.redhat_00017.1.el8jws +8
- Red Hat JBoss Web Server 5.7 for RHEL 9 jws5-tomcat-9.0.62-19.redhat_00017.1.el9jws, jws5-tomcat-admin-webapps-9.0.62-19.redhat_00017.1.el9jws, jws5-tomcat-docs-webapp-9.0.62-19.redhat_00017.1.el9jws +8
- RHSA-2023:3722 Released 2023-06-21 · Red Hat rating Moderateopenssl security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 9) openssl-devel-1:3.0.7-16.el9_2, openssl-perl-1:3.0.7-16.el9_2
- Red Hat Enterprise Linux BaseOS (v. 9) openssl-1:3.0.7-16.el9_2, openssl-libs-1:3.0.7-16.el9_2
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Web Server 3 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:3722 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2023:3722 |
| Red Hat JBoss Core Services | Fixed | RHSA-2023:7626 |
| Red Hat JBoss Core Services on RHEL 7 Server | Fixed | RHSA-2023:7625 |
| Red Hat JBoss Core Services on RHEL 8 | Fixed | RHSA-2023:7625 |
| Red Hat JBoss Web Server 5 | Fixed | RHSA-2023:7623 |
| Red Hat JBoss Web Server 5.7 for RHEL 7 Server | Fixed | RHSA-2023:7622 |
| Red Hat JBoss Web Server 5.7 for RHEL 8 | Fixed | RHSA-2023:7622 |
| Red Hat JBoss Web Server 5.7 for RHEL 9 | Fixed | RHSA-2023:7622 |
Not affected: 7 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat JBoss Core Services on RHEL 7 Server
- Red Hat JBoss Core Services on RHEL 8
- Red Hat JBoss Web Server 5.7 for RHEL 7 Server
- Red Hat JBoss Web Server 5.7 for RHEL 8
- Red Hat JBoss Web Server 5.7 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0464
- 2026-10-03 Alias added: GHSA-w2w6-xp88-5cvw
- 2026-10-09 Fix available: RHSA-2023:7626 · Red Hat
- 2026-10-16 EPSS moved to the 90th–95th percentile
- 2026-10-16 Fix available: Red Hat JBoss Core Services · Red Hat
References
Advisory 1
More Openssl vulnerabilities
- TI-2022-01915 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
- TI-2021-02645 SM2 Decryption Buffer Overflow CVSS 3.1CRITICAL 9.8
- TI-2009-03392 The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft… CVSS 3.1CRITICAL 9.8
- TI-2022-01176 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2025-14107 Stack buffer overflow in CMS (Auth)EnvelopedData parsing CVSS 3.1HIGH 8.8
Sources
- CVE-2023-0464 · CVE Program
- CVE-2023-0464 · NVD
- FIRST EPSS
- GHSA-w2w6-xp88-5cvw · GitHub Advisory Database · CC BY 4.0
- CVE-2023-0464 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences