WP Education < 1.2.7 - Arbitrary Plugin Activation via CSRF
Priority MEDIUM 53CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The WP Education WordPress plugin before 1.2.7 does not have CSRF check when activating plugins, which could allow attackers to make logged in admins activate arbitrary plugins present on the blog via a CSRF attack
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00252 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Education (Unknown): 1.2.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Education | before 1.2.7 | 1.2.7 | Patch available | CNA |
- WP Education VendorUnknown Affected before 1.2.7 Fixed in 1.2.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasthemes:wp_education:*:*:*:*:*:wordpress:*:* | before 1.2.7 | Vulnerable | devitemsllc |
- cpe:2.3:a:hasthemes:wp_education:*:*:*:*:*:wordpress:*:* Versions before 1.2.7 Vulnerable ·devitemsllc
Remediation
- Fix · CNA WP Education (Unknown) Fixed in 1.2.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0498
- 2026-10-03 Alias added: GHSA-mp9p-qpqf-4w9m
References
More devitemsllc Wp Education vulnerabilities
- TI-2024-33116 WordPress WP Education for Elementor plugin <= 1.2.8 - Stored Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0498 · CVE Program
- CVE-2023-0498 · NVD
- FIRST EPSS
- GHSA-mp9p-qpqf-4w9m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences