Campaign URL Builder < 1.8.2 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Campaign URL Builder WordPress plugin before 1.8.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00444 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Campaign URL Builder (Unknown): 1.8.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Campaign URL Builder | before 1.8.2 | 1.8.2 | Patch available | CNA |
- Campaign URL Builder VendorUnknown Affected before 1.8.2 Fixed in 1.8.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:campaign_url_builder_project:campaign_url_builder:*:*:*:*:*:wordpress:*:* | before 1.8.2 | Vulnerable | Campaign Url Builder Project |
- cpe:2.3:a:campaign_url_builder_project:campaign_url_builder:*:*:*:*:*:wordpress:*:* Versions before 1.8.2 Vulnerable ·Campaign Url Builder Project
Remediation
- Fix · CNA Campaign URL Builder (Unknown) Fixed in 1.8.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0538
- 2026-10-03 Alias added: GHSA-6x72-2h6h-rcwq
References
Sources
- CVE-2023-0538 · CVE Program
- CVE-2023-0538 · NVD
- FIRST EPSS
- GHSA-6x72-2h6h-rcwq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences