YARPP - Yet Another Related Posts Plugin < 5.30.3 - Subscriber+ SQLi
Priority HIGH 73CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before using them in SQL statement/s, which could allow any authenticated users, such as subscribers to perform SQL Injection attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0094 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed YARPP (Unknown): 5.30.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | YARPP | before 5.30.3 | 5.30.3 | Patch available | CNA |
- YARPP VendorUnknown Affected before 5.30.3 Fixed in 5.30.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yarpp:yet_another_related_posts_plugin:*:*:*:*:*:wordpress:*:* | before 5.30.3 | Vulnerable | jeffparker |
- cpe:2.3:a:yarpp:yet_another_related_posts_plugin:*:*:*:*:*:wordpress:*:* Versions before 5.30.3 Vulnerable ·jeffparker
Remediation
- Fix · CNA YARPP (Unknown) Fixed in 5.30.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0579
- 2026-10-03 Alias added: GHSA-g76w-533m-p23h
References
More jeffparker Yet Another Related Posts Plugin vulnerabilities
- TI-2024-29508 WordPress Yet Another Related Posts Plugin (YARPP) plugin <= 5.30.10 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-22340 WordPress Yet Another Related Posts Plugin (YARPP) plugin <= 5.30.4 - Local File Inclusion CVSS 3.1HIGH 7.7
- TI-2022-04086 YARPP - Yet Another Related Posts Plugin < 5.30.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-02286 YARPP – Yet Another Related Posts Plugin <= 5.30.3 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2023-05952 YARPP – Yet Another Related Posts Plugin <= 5.30.9 - Authenticated(Administrator+) Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-00557 Cross-site scripting in jeffparker YARPP – Yet Another Related Posts Plugin CVSS 3.1MEDIUM 4.4
Sources
- CVE-2023-0579 · CVE Program
- CVE-2023-0579 · NVD
- FIRST EPSS
- GHSA-g76w-533m-p23h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences