YAFNET Signature cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in YAFNET up to 3.1.11 and classified as problematic. This issue affects some unknown processing of the component Signature Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.12 is able to address this issue. The identifier of the patch is a1442a2bacc3335461b44c250e81f8d99c60735f. It is recommended to upgrade the affected component. The identifier VDB-220037 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | YAFNET | 3.1.0; 3.1.1; 3.1.2; 3.1.3; 3.1.4; 3.1.5; 3.1.6; 3.1.7; 3.1.8; 3.1.9; 3.1.10; 3.1.11 | — | No fix listed | CNA |
- YAFNET Vendor— Affected 3.1.0; 3.1.1; 3.1.2; 3.1.3; 3.1.4; 3.1.5; 3.1.6; 3.1.7; 3.1.8; 3.1.9; 3.1.10; 3.1.11 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yetanotherforum:yaf.net:*:*:*:*:*:*:*:* | up to 3.1.11 | Vulnerable | Yetanotherforum |
- cpe:2.3:a:yetanotherforum:yaf.net:*:*:*:*:*:*:*:* Versions up to 3.1.11 Vulnerable ·Yetanotherforum
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0650
- 2026-10-03 Alias added: GHSA-mvrc-wwg3-6rfm
References
Exploit 2
More Yetanotherforum Yaf.net vulnerabilities
- TI-2023-00520 YAFNET Private Message PostPrivateMessage cross site scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-0650 · CVE Program
- CVE-2023-0650 · NVD
- FIRST EPSS
- GHSA-mvrc-wwg3-6rfm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences