Popup Builder by OptinMonster < 2.12.2 - Subscriber+ Arbitrary Post Content Disclosure
Priority MEDIUM 62Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Popup Builder by OptinMonster WordPress plugin before 2.12.2 does not ensure that the campaign to be loaded via some shortcodes is actually a campaign, allowing any authenticated users such as subscriber to retrieve the content of arbitrary posts, like draft, private or even password protected ones.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00778 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Popup Builder by OptinMonster (Unknown): 2.12.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Builder by OptinMonster | before 2.12.2 | 2.12.2 | Patch available | CNA |
- Popup Builder by OptinMonster VendorUnknown Affected before 2.12.2 Fixed in 2.12.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:optinmonster:optinmonster:*:*:*:*:*:wordpress:*:* | before 2.12.2 | Vulnerable | OptinMonster |
- cpe:2.3:a:optinmonster:optinmonster:*:*:*:*:*:wordpress:*:* Versions before 2.12.2 Vulnerable ·OptinMonster
Remediation
- Fix · CNA Popup Builder by OptinMonster (Unknown) Fixed in 2.12.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0772
- 2026-10-03 Alias added: GHSA-w5vw-x33c-r8g6
References
More Optinmonster vulnerabilities
- TI-2021-16708 OptinMonster <= 2.6.4 Unprotected REST-API Endpoints CVSS 3.1HIGH 8.2
- TI-2021-16695 OptinMonster <= 2.6.0 Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-03774 Cross-site scripting in smub Popup Builder & Popup Maker for WordPress – OptinMonster… CVSS 3.1MEDIUM 6.4
- TI-2016-09034 The optinmonster plugin before 1.1.4.6 for WordPress has incorrect access control for… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-0772 · CVE Program
- CVE-2023-0772 · NVD
- FIRST EPSS
- GHSA-w5vw-x33c-r8g6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences