Formidable Forms < 6.1 - IP Spoofing
Priority HIGH 68CWE-290Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-290.
Summary
The Formidable Forms WordPress plugin before 6.1 uses several potentially untrusted headers to determine the IP address of the client, leading to IP Address spoofing and bypass of anti-spam protections.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00498 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Formidable Forms (Unknown): 6.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Formidable Forms | before 6.1 | 6.1 | Patch available | CNA |
- Formidable Forms VendorUnknown Affected before 6.1 Fixed in 6.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strategy11:formidable_form_builder:*:*:*:*:*:wordpress:*:* | before 6.1 | Vulnerable | strategy11team |
- cpe:2.3:a:strategy11:formidable_form_builder:*:*:*:*:*:wordpress:*:* Versions before 6.1 Vulnerable ·strategy11team
Remediation
- Fix · CNA Formidable Forms (Unknown) Fixed in 6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0816
- 2026-10-03 Alias added: GHSA-m9ch-6hh2-gc9w
References
More strategy11team Formidable Form Builder vulnerabilities
- TI-2021-07166 Formidable Form Builder < 4.09.05 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1CRITICAL 9.6
- TI-2019-11851 The formidable plugin before 4.02.01 for WordPress has unsafe deserialization. CVSS 3.1CRITICAL 9.8
- TI-2017-14258 Formidable Form Builder < 2.05.03 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 8.3
- TI-2023-10041 WordPress Formidable Forms Plugin <= 5.5.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-06236 Formidable Forms <= 6.7 - HTML Injection CVSS 3.1MEDIUM 6.5
- TI-2017-14260 Formidable Form Builder < 2.05.03 - Unauthenticated Information Disclosure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-0816 · CVE Program
- CVE-2023-0816 · NVD
- FIRST EPSS
- GHSA-m9ch-6hh2-gc9w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences