Kanban Boards for WordPress < 2.5.21 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Kanban Boards for WordPress plugin before 2.5.21 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00548 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Kanban Boards for WordPress (Unknown): 2.5.21
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Kanban Boards for WordPress | before 2.5.21 | 2.5.21 | Patch available | CNA |
- Kanban Boards for WordPress VendorUnknown Affected before 2.5.21 Fixed in 2.5.21 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kanbanwp:kanban_boards_for_wordpress:*:*:*:*:*:wordpress:*:* | before 2.5.21 | Vulnerable | Kanban for WordPress |
- cpe:2.3:a:kanbanwp:kanban_boards_for_wordpress:*:*:*:*:*:wordpress:*:* Versions before 2.5.21 Vulnerable ·Kanban for WordPress
Remediation
- Fix · CNA Kanban Boards for WordPress (Unknown) Fixed in 2.5.21
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0873
- 2026-10-03 Alias added: GHSA-8j78-9w7g-w7xq
References
More Kanban for WordPress Kanban Boards For Wordpress vulnerabilities
- TI-2023-21404 WordPress Kanban Boards for WordPress Plugin <= 2.5.21 is vulnerable to Arbitrary Code Execution CVSS 3.1CRITICAL 9.1
- TI-2023-09683 WordPress Kanban Boards for WordPress Plugin <= 2.5.20 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-0873 · CVE Program
- CVE-2023-0873 · NVD
- FIRST EPSS
- GHSA-8j78-9w7g-w7xq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences