Stagtools < 2.3.7 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The StagTools WordPress plugin before 2.3.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00444 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed StagTools (Unknown): 2.3.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | StagTools | before 2.3.7 | 2.3.7 | Patch available | CNA |
- StagTools VendorUnknown Affected before 2.3.7 Fixed in 2.3.7 Patch available CNA
Remediation
- Fix · CNA StagTools (Unknown) Fixed in 2.3.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0891
- 2026-10-03 Alias added: GHSA-mpr2-vg4h-vhcp
References
More Codestag Stagtools vulnerabilities
- TI-2023-22261 WordPress Stagtools Plugin <= 2.3.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
Sources
- CVE-2023-0891 · CVE Program
- CVE-2023-0891 · NVD
- FIRST EPSS
- GHSA-mpr2-vg4h-vhcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences