Japanized For WooCommerce < 2.5.8 - Reflected XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Japanized For WooCommerce WordPress plugin before 2.5.8 does not escape generated URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0085 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Japanized For WooCommerce (Unknown): 2.5.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Japanized For WooCommerce | before 2.5.8 | 2.5.8 | Patch available | CNA |
- Japanized For WooCommerce VendorUnknown Affected before 2.5.8 Fixed in 2.5.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:artisanworkshop:japanized_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 2.5.8 | Vulnerable | Artisanworkshop |
- cpe:2.3:a:artisanworkshop:japanized_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 2.5.8 Vulnerable ·Artisanworkshop
Remediation
- Fix · CNA Japanized For WooCommerce (Unknown) Fixed in 2.5.8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0948
- 2026-10-03 Alias added: GHSA-jf29-vf7j-2f4w
References
More Artisanworkshop Japanized For Woocommerce vulnerabilities
- TI-2023-00893 Japanized For WooCommerce <= 2.5.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-0948 · CVE Program
- CVE-2023-0948 · NVD
- FIRST EPSS
- GHSA-jf29-vf7j-2f4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences