Read the docs
TI-2023-00901 Aliases CVE-2023-0950GHSA-qv23-hw3g-384q

Array Index UnderFlow in Calc Formula Parsing

Priority LOW 36CWE-129Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 4 fixed, 3 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-129 and the CVSS impact.

Summary

Improper Validation of Array Index vulnerability in the spreadsheet component of The Document Foundation LibreOffice allows an attacker to craft a spreadsheet document that will cause an array index underflow when loaded. In the affected versions of LibreOffice certain malformed spreadsheet formulas, such as AGGREGATE, could be created with less parameters passed to the formula interpreter than it expected, leading to an array index underflow, in which case there is a risk that arbitrary code could be executed. This issue affects: The Document Foundation LibreOffice 7.4 versions prior to 7.4.6; 7.5 versions prior to 7.5.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.003 22nd percentileScored 2026-11-07
Fix Partial LibreOffice (The Document Foundation): 7.4.6, 7.5.1Red Hat: 2 advisoriesRed Hat: 4 fixed, 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
The Document FoundationLibreOffice7.4 to before 7.4.6; 7.5 to before 7.5.17.4.6, 7.5.1Patch availableCNA
  • LibreOffice VendorThe Document Foundation Affected 7.4 to before 7.4.6; 7.5 to before 7.5.1 Fixed in 7.4.6, 7.5.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:*7.4.0 to before 7.4.6; 7.5.0 to before 7.5.2VulnerableThe Document Foundation
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* Versions 7.4.0 to before 7.4.6; 7.5.0 to before 7.5.2 Vulnerable ·The Document Foundation
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · CNA LibreOffice (The Document Foundation) Fixed in 7.4.6, 7.5.1

Red Hat 2 advisories

  • RHSA-2023:6933 Released 2023-11-14 · Red Hat rating Moderate
    libreoffice security update
    • Red Hat CodeReady Linux Builder (v. 8) libreoffice-sdk-1:6.4.7.2-15.el8, libreoffice-sdk-doc-1:6.4.7.2-15.el8
    • Red Hat Enterprise Linux AppStream (v. 8) autocorr-af-1:6.4.7.2-15.el8, autocorr-bg-1:6.4.7.2-15.el8, autocorr-ca-1:6.4.7.2-15.el8 +47
  • RHSA-2023:6508 Released 2023-11-07 · Red Hat rating Moderate
    libreoffice security update
    • Red Hat CodeReady Linux Builder (v. 9) libreoffice-sdk-1:7.1.8.1-11.el9, libreoffice-sdk-doc-1:7.1.8.1-11.el9
    • Red Hat Enterprise Linux AppStream (v. 9) autocorr-af-1:7.1.8.1-11.el9, autocorr-bg-1:7.1.8.1-11.el9, autocorr-ca-1:7.1.8.1-11.el9 +47

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    The Document Foundation LibreOffice — GLSA-202311-15

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2023-02114 Remote documents loaded without prompt via IFramePriority LOW 28
  • Advisory ·

    The Document Foundation LibreOffice — DSA-5415

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2023-02114 Remote documents loaded without prompt via IFramePriority LOW 28

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 9AffectedNo fix planned: Will not fix
Red Hat CodeReady Linux Builder (v. 8)Fixed RHSA-2023:6933
Red Hat CodeReady Linux Builder (v. 9)Fixed RHSA-2023:6508
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:6933
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:6508
Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0950
  2. 2026-10-03 Alias added: GHSA-qv23-hw3g-384q

References

  • TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
  • TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
  • TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
  • TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
  • TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
  • TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
See all 70 →

Sources